Jump to content
Escort Cabriolet Club
Sign in to follow this  
prox71

Electric aerial wiring

Recommended Posts

I have 1989 Escort Xr3i Cabriolet

Took out electric  aerial in boot that was working fine, to replace tip of aerial as it had broken off.

On refitting I am receiving no power in the constant live (red) wire, have tested the aerial with external power works fine so not a problem with the aerial.

The ignition wire was making the relay in the aerial click but that has now stopped aswell.

Have checked all fuses in the fuse box, all seem fine, 2 amp fuse behind stereo is ok, aerial works if you wire it direct from boot to the stereo with different wires.

Before I just fit new wires from the stereo to the boot along the sills, does anyone know if this is a hidden fuse somewhere or is it likely the wires have shorted(maybe the live touched the shell on removal - my own stupid fault always disconnect battery first), also what is the route of the wires do they go under the sills and into the dash on passenger side? 

 

Share this post


Link to post
Share on other sites

I have this exact issue with mine. No power in red cable but the other cable has power when headunit switched on

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×