Jump to content
Escort Cabriolet Club

matt1356

Forum Members
  • Content Count

    2
  • Joined

  • Last visited

  1. I've been working on getting my mk5 Escort Xr3i 130 cabby back on the road during lockdown. So far I've cut out and fixed the rust on both the lower front wings, the rear wheel arches, both outer sills and the battery panel. Whilst waiting for some filler to cure I thought I'd take a look at the roof which was working when I took the car off the road but then stopped working on the driveway. First of all I tested all of the relays and fuses using a multimeter and found no issues. For anyone troubleshooting this sort of issue a multimeter is essential and will save you a lot of cash in the long run (there are some excellent tutorials on youtube on how to test car relays!) I then connected the battery directly to the roof pump using a car battery via crocodile clips and the pump kicked in so I was pretty sure it was a power issue. After much head scratching I took a look at the wiring in the battery panel area and found the red one shown in the pics had frayed and broken free, I guessed that must be the power wire for the electric roof. I then cut the end of the wire, exposed some fresh copper and re-crimped/soldered the connector. The roof now works, easy fix!! Hope this helps someone out there.
  2. Welcome to Escort Cabriolet Club. Please feel free to browse around and get to know the others. If you have any questions please don't hesitate to ask.

×
×
  • Create New...