Jump to content
Escort Cabriolet Club
Sign in to follow this  
DaveH

Clutch.

Recommended Posts

Hi all

I have fitted a new complete clutch including cable and ratchet to my mk4 cabby, the problem i was having was i had to put the pedal to the floor to get it in gear.

since i have don the work the ratchet keeps slipping i know its not the ratchet because it was doing it with the old one, thats why i replaced it any ideas/help would be realy appreciated.

Thanks.

Share this post


Link to post
Share on other sites

What make is the clutch and was it genuine Ford parts cable, and ratchet/ pawl assembly you used? Check the fork arm at the gear box housing,  I just replaced my cluthc with a LUK, and original Ford cable, and ratchet and Pawl, but found it was an internal gearbox issue. Luckily I swapped the gearbox (as I had a NOS gearbox and all is fine now! But oringinally I used Q&H and it was so poor. I lost out on the labour Q&H after a year refunded me with the money but it had done damage to the gearbox. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...