Jump to content

  •  


Toggle Escort Cabriolet Club Messages

Hello and welcome to The Escort Cabriolet Club

Like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information.

To take advantage of it immediately Click here!

There are many great features that are not available to guests at the Escort Cabriolet Club including:

You are able to view and shout to the shoutbox, you are able to post in the forum, you are able to use the gallery.

We would like you to register and come and join us, and join in.

Alternatively why not become an Escort Cabriolet Club member.


Photo

Blower Has Stopped Working


  • Please log in to reply
3 replies to this topic

#1 ELK100

ELK100

    Newbie

  • Forum Members
  • Pip
  • 5 posts
  • Gender:Male
  • Location:Nottingham

Posted 09 November 2017 - 08:01 AM

Now the summer is over and water has started to form on the windscreen, my blower has stopped working. I'm going to get the mutimeter out (I can hear you shout!) but wonder if anyone else has had a similar problem? I've read about the fuseboards being replaced, direct cables being run from the battery to bypass the board. The resistor and/ or switch being replaced. The cabby is a P- Reg 1996 Ghia 1.8. Anyone got a fuseboard for it?    


  • 0

#2 sifitz

sifitz

    Member

  • Forum Members
  • PipPip
  • 75 posts
  • Gender:Male
  • Location:maidstone kent

Posted 09 November 2017 - 06:24 PM

hi I have a mk6 ghia that I am breaking I live in Maidstone Kent if you need any parts if you live near you can bring your car and try the part you need before buying it to make sure it fixes the fault
  • 0

#3 ELK100

ELK100

    Newbie

  • Forum Members
  • Pip
  • 5 posts
  • Gender:Male
  • Location:Nottingham

Posted 11 November 2017 - 03:19 PM

Hi, Thanks for the offer. As soon as I find out what it is I'll be in touch.


  • 0

#4 ELK100

ELK100

    Newbie

  • Forum Members
  • Pip
  • 5 posts
  • Gender:Male
  • Location:Nottingham

Posted 30 November 2017 - 05:01 PM

What a hassle that was, but the blower is back in action. The blower and resistor in my Mk6 are under the wiper mechanism at the very back of the engine compartment. To get to it you have to remove a large plastic protector above the fan housing that just defied removal. OK it had been there for 21 years! After a lot of pulling it came out in one piece.

Undoing the fan housing was easy but getting it out the engine compartment meant removing the battery and lifting many cables out of the way. The fan had seized and the resistor looked shot so decided to replace both with new parts (didn't want to put a second hand blower and resistor in only for either of them to need replacement again). Managed to get both blower and resistor from the famous online store and refitted everything. BUT, the plastic housing completely refused to go back to its original position and is held, albeit fairly securely, by its two screws. 

Turning on the blower and finding that it worked should have ended a very satisfying day, but every time I opened a vent,  leaves and debris shot all over the front seats and carpet. Still I suppose the repair could have been a lot worse.......


  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Welome guest to the Escort Cabriolet Club!
Please Login or Register to use the full featues

Join The Escort Cabriolet Club

Join The Escort Cabriolet Club