Jump to content

  •  


Toggle Escort Cabriolet Club Messages

Hello and welcome to The Escort Cabriolet Club

Like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information.

To take advantage of it immediately Click here!

There are many great features that are not available to guests at the Escort Cabriolet Club including:

You are able to view and shout to the shoutbox, you are able to post in the forum, you are able to use the gallery.

We would like you to register and come and join us, and join in.

Alternatively why not become an Escort Cabriolet Club member.


Photo

Escort Mk 6 Cabby Heated Front Windscreen Issues


  • Please log in to reply
3 replies to this topic

#1 ELK100

ELK100

    Newbie

  • Forum Members
  • Pip
  • 2 posts
  • Gender:Male
  • Location:Nottingham

Posted 06 October 2017 - 06:00 PM

Hi, This is my first post so I hope someone has come across a similar problem? I upgraded my front windscreen of my 1996 cabby ghia to a heated front windscreen. All worked well until recently when the switch light came on very briefly then went off. It continues to do this when the switch is depressed and there's no front windscreen demisting. The switch is not at fault as I've changed it for the one in my Ghia X that I know works. I don't think its the relay as I've swapped that as well. I've disconnected all the plugs and sprayed them with wd40 in case there's dampness present. So I'm at a bit of a loss. Any suggestions anybody?

 


  • 0

#2 Paul Grainger

Paul Grainger

    Advanced Member

  • Forum Members
  • PipPipPip
  • 140 posts
  • Gender:Male
  • Location:Paignton
  • Interests:Sailing and Cabrioleting

Posted 07 October 2017 - 04:26 AM

Time to get the multimeter out!
Does the relay click? That will tell you which side of the relay is faulty.
  • 0

#3 ELK100

ELK100

    Newbie

  • Forum Members
  • Pip
  • 2 posts
  • Gender:Male
  • Location:Nottingham

Posted 12 October 2017 - 11:39 AM

No the relay didn't click,  so one ebay relay purchase later and the front heated screen works again. Thanks for the tip.


  • 0

#4 Paul Grainger

Paul Grainger

    Advanced Member

  • Forum Members
  • PipPipPip
  • 140 posts
  • Gender:Male
  • Location:Paignton
  • Interests:Sailing and Cabrioleting

Posted 15 October 2017 - 04:43 AM

Great stuff!


  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Welome guest to the Escort Cabriolet Club!
Please Login or Register to use the full featues

Join The Escort Cabriolet Club

Join The Escort Cabriolet Club